hifi engine

Manual Library / Luxman

Luxman 5C50

DC Integrated Pre Amplifier (1978-81)

add a review add a review

Luxman 5C50


Although it is the basic role for an amplifier to amplify the music signals faithfully, this is in actual practice hard to be carried out.

Music signals are, as you know, the wave signals that are never repeated, therefore, not only the wave form but the time lag (phase characteristics) must be considered for the high fidelity amplification.

We have titled the 5C50 with the indication Real Time Processed, since we have been delving into the phase characteristics and obtained a satisfactory solution.

We have adopted a DC-amp configuration in order to improve phase distortion in low frequency as well as transient distortion in high frequency range.

Also several measures have been bestowed to eliminate non linear distortion which appears only at the time of actual use, when connecting cartridge etc


Frequency response: 1Hz to 200kHz

Total harmonic distortion: 0.005%

Input sensitivity: 2.5mV (MM), 150mV (line)

Signal to noise ratio: 80dB (MM), 100dB (line)

Output: 150mV (line), 1V (Pre out), 18V (Pre out Max)

Dimensions: 442 x 400 x 101mm

Weight: 8.2kg


service manual   English - Ivy Caudieus

schematic   English - Ivy Caudieus

instruction/owners manual   English - Ivy Caudieus

Related Catalogues

Complete Audio Products

Laboratory Reference Series


Ultimate High Fidelity Stereo Components

If you have any problems opening files please read the download FAQ. All files are provided under strict licence and reproduction without prior permission or for financial gain is strictly prohibited.

If you have additional documentation please consider donating a copy to our free archive.


re: 5C50

I just got the Luxman 5C50 form a friend and got new DML-02 units installed. Everything worked fine for about 3 months. Now it just happens to be very unstable. Sometimes the regulated +-30V supply goes crazy, looks like a short circuit somewhere but the fault is intermittent. i tried to disconnect the phono section and at first i got the unit to work but when it cooled down i got that fault again. there is something wrong probably in the flat amp section but what could be dragging the power supply down to nothing? Since the negative rail is referenced to the positive rail, it needs the +30V to be correct and as i see +2.2V on the + side, the - side is completely off voltage as well. Any clues? this unit is so well made, and so beautiful i don't want to give up and when it worked, the sound was absolutely fabulous.

This website is not affiliated with or sponsored by Luxman. To purchase 5C50 spares or accessories, please contact the company via their website or visit an authorised retailer.