hifi engine

Aiwa cs 702d II

The Play button doesn't engage unless I hold it down lightly and allow the flywheel to spin up first. I just bought this unit used and I've opened it and lightly cleaned and lubricated with WD40.

Any suggestions?

Thanks,
Jwilly



Re: Aiwa cs 702d II

Now, the Play button engages but, it slows down and sounds very sluggish.

Re: Aiwa cs 702d II

I don't recommend WD-40 for anything except maybe car door locks. I would try again with a good tuner or control cleaner.

Re: Aiwa cs 702d II

The problem existed before I used the WD40 but it actually helped a bit. Thanks, I wiped it all off. The problem persists. I am trying to determine if I need a new motor or is there something I am overlooking with the belts or other mechanism.

Re: Aiwa cs 702d II

Aiwa or akai ? either way WD40 is a definite no go for any electronics , leave it for the car and rusty bolts its great .
If it is an akai that lines up with that model number you will probably find some metal plate that slide in the mechanism which are used to hold the buttons down after being pressed and may be part of the auto stop if it has one , these plates usually had some grease between them that could harden over time , this needs to be cleaned off and replaced , the wd40 would just make it sticky and gum up the works a white silicon grease is your best bet but this does need the whole mechanism to be pulled down and reassembled which can be a bit tricky if you haven't done it before .

Re: Aiwa cs 702d II

Yes it is an Akai and does have auto stop. I have white silicon grease in a spray. Downloaded the repair manual so hopefully I can figure out how to put it back together.
Thanks for the help.