hifi engine

How do I connect a Kenwood GE820 graphic equalizer to a NAD 3020 amplifier?

Have been trying to connect my Kenwood GE820 graphic to my NAD amp but I am not sure what connects go where as there are line in and out and ADAPTER in/out. Also where do I run the leads from on the Amp?



Re: How do I connect a Kenwood GE820 graphic equalizer to a ...

The pre-amp out (adapter out) of the NAD goes to the input of the EQ; the output of the EQ goes to the Amp in on the NAD. Remove the jumpers if they are there.

Not sure what you mean by 'where do I run the leads from the amp?'. Speaker wires go to the speakers from the A and B connectors.

Re: How do I connect a Kenwood GE820 graphic equalizer to a ...

Hi there and thank you for trying to help. I now have the visual of the spectrum bars going up and down but no sound. The only source I can select is AUX on the front facia of the NAD which gets the bars going up and down. The sound is very distant as if I have it on the wrong selector on the amp but I have tried all the others and there is no response from the graphic at all which is incidentally set to line in for the bars to come to life. Apart from that I have done everything you asked?
I have am using the "Normal in" on the NAD and not the " LAB IN"

Marcus.

Re: How do I connect a Kenwood GE820 graphic equalizer to a ...

Thank you again for your help. I have managed to get round the problem with an alternative method of connecting the two which is " Pre out to "Line in" then "Rec out" to "Normal in" :-)

Marcus.