hifi engine

Pioneer SX-2900

My vintage Pioneer SX-2900 stereo receiver no longer produces audio output in either channel. The problem seemed to be occurring gradually over a period of a few weeks. Noticed that it would have audio output when first turned on then lose audio after playing for a while. Each time I checked the speaker output terminals and after a quick disconnect and re-connect of the speaker cables the audio would come back and be fine. But after losing the audio this last time I can't get it back. Pressed the "return" button but no help. Checked all the connections and they seemed to be fine. Checked out the speakers by connecting them to another receiver and they work OK. Replaced the speaker cables but still no audio. Pulled the cover off and found 3 fuses which had no sign of being blown.
Any suggestions about what to check next?



Re: Pioneer SX-2900

You could have dirty protection relay contacts, dirty tape monitor switches, or poor connections in any audio circuit. You can first try actuating the tape monitor switches several times.

Re: Pioneer SX-2900

Thanks...tried activating all the switches several times but still no audio. Any other suggestions?
I found a local repair shop that still does work on vintage stereo receivers and is willing to take a look at it for a nominal fee. But after looking online to see what comparable new receivers are going for I'm guessing that unless it's a simple fix it will be more cost effective to scrap the 20 year old model for something new.
What do you think?

Re: Pioneer SX-2900

eBay sales for the sx2900 are about $15-25, so it's not a valuable receiver.