hifi engine

Revox PR99 MK2 channel 2 no sound

My Revox Pr99 MK2 doesn't give any sound when I playback a tape. Also the channel 2 VU-meter stays 0 and the headphone output mutes on channel 2. Futhermore the input signal e.g record also failed to respond on channel 2. I gues an OP IC on the reproduce PCB is defect, do you think this is correct with the symptoms I gave?



karodimitrov's picture

Re: Revox PR99 MK2 channel 2 no sound

In such cases to track the signal I use remaking headphones-ground and 2 wires(left & right ch.)
connected together.Then ground of the headphones i grounded,and another(double) cable connect with capacitor about 10 Mf.Touching the other end of the capacitor (+ of the cap.) to mainboard using scheme
you can track the signal and find where is lost.Watching scheme you can begin from point "D" after IC of the reproduce PCB.Turn on playback and search!Thus you can check all inputs,outputs...
This works.Many times for me-hope and for you.

Re: Revox PR99 MK2 channel 2 no sound

Unfortunately the IC's of the reproduce PCB and the IC's/Transitors q1 til q4 on the output PCB did not solve the problem. Channel two is still not working. Also in input mode, headphones, monitor and output 2 it gives no signal.
I don't understand the headphones failure test as mentioned above. Could you please be more specific? The pcb boards are so close to eachother where to measure?

karodimitrov's picture

Re: Revox PR99 MK2 channel 2 no sound

Just using your headphones as a signal detector and the music-like signal. Walking in the signal path (somewhere very quiet, other louder), you will find the point where it disappears. May extend earphone terminals with multimeter cables.
The electrolytic capacitor connected to the headphones galvanically separates them from the board. So there is no danger of the circuit and protect headphones from DC-if you accidentally touch the power circuit.

Re: Revox PR99 MK2 channel 2 no sound

I connected a Beosound 1 as monitor speaker to the monitor DIN bus. According to the scheme it gets it's signal from the reproduce unit. Again I hade only sound on channel 1. I ordered two IC's which are OP ampiflers the RC4559 and I'm going to replace them, I hope this will solve the problem. If not I have to look futher. The failure of the reproduce PCB is still my best option since the knob to choose between ch1, ch2, reverse, stereo, mono gives these signals only on channel 1 and when I turn on the machine the VU meters hit out briefly. Thank you for thinking with me!

Re: Revox PR99 MK2 channel 2 no sound

have you checked the input/output switch located beside the power switch, it selects what the vu meters show, if it is not on channel 2, it will give you these problems

Re: Revox PR99 MK2 channel 2 no sound

Yes, this switch is in reproduce mode, only channel 1 works.