hifi engine

Studer A807 Mono

yashoda rohana's picture

Recently I got a Studer A807 Mono Tape Recorder for free. The machine powers up but no lights in the vu meter and when I try to run a tape it tries to start then it stops. so I removed the back panel and found that the 4 amp fuse and the 10uF 63v cap on the bottom board has blown up.

after replacing these components is there anything more that I should look out for in this type of machines. I'm not very familiar with studer tape recorders because I mostly own and repaired Japanese tape recorders.

I also want to know whether its a MKii or not, how to recognize it

I couldn't find the schematic for the machine so if anybody know where to find please give the link for it.

Thank you.



yashoda rohana's picture

Re: Studer A807 Mono

I replaced both the fuse and the cap but still the fuse keeps blowing when I turn on the machine. so I traced down the wires to the Franko caps and they seemed to be fine but when I checked the rectifier it was shorted so replaced that too. But still the same problem so again I traced down the problem to the capstan control board where 2 of the power transistors were completely dead.
I have to replace those and check again.

Thank you.

Re: Studer A807 Mono

One good advice from the expert repair of audio, any device that come to you, check BEFORE you switch on the power voltage, the presence of visual defects of the electronic with test unit , and test the device for bad moments, especially transistors and diodes and bad soldering, and short circuit.