hifi engine

LEAK 2000 1973

RobdeFries's picture

in


LEAK 2000 1973

Good looking receiver. There seems to be versions with other on/off and wave selector. The pointer knobs on this example are awesome. Nice symetric design.




Comments

Re: LEAK 2000 1973

After 43 years (recently of only occasional use) my receiver has no output from one channel. Now living in Australia and contemplating getting it repaired. This was an excellent receiver in its day, and was until recently - playing through Celestion Ditton (25's I think).

Re: LEAK 2000 1973

Hi , your receiver seem to be ok, if some parts burnt out it would no sound come out .You try to clean up the connector or selector of the receiver with W40,of course must take off the power plug first and wait about couple minutes for the W40 dry up ,G ood luck to you

Re: LEAK 2000 1973

Hi Martin, thanks for your response. Is W40 a switch cleaner? I assume not WD40 - the residual oil would attract dust. Nothing came up on a search. Rgds Andrew

Re: LEAK 2000 1973

Hi. I bought a Kenwood 8010 receiver on Ebay recently. it is sell for part .Because only power light on but no sound .I cleaned it with Supertech Lubricant that bought in Walmart under $2.00 dollars for it is cheaper than WD40. Checking for the selector and other connector inside of receiver (speaker switch turn it many times after spray lubricant) . my receiver work with beautiful sound .Attention,Before do anything inside the receiver must unplug the power cord .Take off any power connector from home's power supple for safety , after clean up dry it with rag . Do not spray to the power transistor or power supply in the receiver. If still not work, please check for any connector loose contact .Good luck again.