hifi engine

Manual Library / JVC

JVC R-X300

Stereo AM/FM Receiver

add a review add a review

JVC R-X300

Specifications

  • Tuning range: FM, MW

    Power output: 55 watts per channel into 8Ω (stereo)

    Frequency response: 5Hz to 50kHz

    Total harmonic distortion: 0.003%

    Damping factor: 45

    Input sensitivity: 2.5mV (MM), 190mV (line)

    Signal to noise ratio: 71dB (MM), 100dB (line)

    Output: 190mV (line)

    Dimensions: 435 x 341 x 117mm

    Weight: 6.8kg

    Year: 1984

  • Tuning range: FM, MW, LW

    Power output: 55 watts per channel into 8Ω (stereo)

    Frequency response: 5Hz to 50kHz

    Total harmonic distortion: 0.003%

    Damping factor: 45

    Input sensitivity: 2.5mV (MM), 190mV (line)

    Signal to noise ratio: 71dB (MM), 100dB (line)

    Output: 190mV (line)

    Dimensions: 435 x 341 x 117mm

    Weight: 6.8kg

    Year: 1984

Downloads

Comments

re: R-X300

question ? tuner presets not retained after power is swithched off. the battery compartment checked ok 2 good AAs I see no bulging caps no cold solder joints no burned resisters. Is there a main capacitor that stores energy to remember preset info ? Going to recap tuner board anyway. Pardon my ignorance I am just a hobbiest. I resoldered battery terminals I seen some corrosion.

re: R-X300

I have exact same issue with tuner presets not being retained after powering down. Did you solve your particular issue? I'm not savy with electronics and a repair shop want $85 just to even look at it. If I'm pointed in the right direction, I can perform basic tests to pinpoint the memory issue. I also have the repair manual from here printed.

re: R-X300

Disregard this post, I found the fuse - it's actually attached to a small PCB outside of the shielding. The front of the PCB is mounted to an opening in the back of the shield. Problem solved.

JVC R-X300 Display

I'm repairing a R-X300 for a display problem. Does anyone know if the LCD panel is pressed into the display PCB? Or is it soldered in?

Thanks,

Bob

JVC R-X300 Reciever, phono won't play

When turn power on the the main screen does note light up, and although the turn table indication light is on, there is no sound produced. Is there maybe a fuse somewhere that would explain this. ps, same thing for tape deck.

main screen does note light up

part number23, fuse on lcd display, is shown in the picture on the parts list you can download from thr R-X300 page. This fuse is located on the back of the lcd and costs $5.66 cents from jvc on yje parts page at: http://www.jvcservice.com/service/JMdlPrtXrf.asp?PgReq=DspDta&MdlNbr=R-X...
Thisnew fuse should restore the light on the lcd display.
No Sound?
Check and make sure your speaker wires are connected correctly to either the A or B terminals on the back of the receiver; and that the A or B speaker buttons are pushed in to to turn on the speakers.

jvc x300

Cannot get to power on. Any suggestions?

This website is not affiliated with or sponsored by JVC. To purchase R-X300 spares or accessories, please contact the company via their website or visit an authorised retailer.